C5 doesn't play nice on a power strip


#1

A customer has been complaining for a couple weeks that his internet is sporadic. I finally get sent there, and 4 hours of testing eventually yields the answer: a projector plugged into the same power strip has been causing the c5 to reboot every 6 minutes. WTF?

This customer has been put on several different types of gear in the last 3 years, as the infrastructure evolved. His things have all been plugged into a power strip for this whole time ( I know, because I’ve done all of it). Cambium didn’t care, Uibiquiti didn’t care, but Mimosa? Mimosa goes haywire. Two different power supplies, and two different radios did the same thing, even with 90 feet of brand new Shireen with tracer grounded to the house’s grounding rod.

It wasn’t until the projector was removed from the power strip that the radio would stay up for 7 minutes.

I don’t mean for this to come across as a rant, but it does leave me wondering how Mimosa can be so far ahead of Ubiquiti in some ways, but so far behind in so many others.


#2

C5+ what? G2? or regular C5-POE?


#3

Try a UBNT POE-48-24W-G power supply and see if that resolves the issue. I’ve had a couple situations where the Mimosa PoE does not behave correctly, but the POE-48-24W-G does.


#4

We have mostly little white wall-warts. A few places have the full-size bricks, but those are only when there are left-overs from b5s or a5s that are powered by netonix switches. While it’s probably a good idea to try using ubiquiti 48v supplies, that’s not feasible, because we don’t have any.

I primarily made this thread as feedback to mimosa. One vocal complaint indicates many dozens, or hundreds of unhappy customers.