2.4 GHz Network Missing B5c

Recently purchased a pair of B5c’s. Unboxed today, upgraded to latest firmware (Same as my other pair that’s working fine). Paired them, and went through my standard configuration settings. Went to configure the 2.4 GHz Network, but the link for that option does not exist. Checked my others that are online, and that option is obviously there. So not sure what’s going on. Rebooted, but still that option is not available. Anyone have any idea what’s going on? Screenshot of “working” vs “not working” attached.

Not Working - missing 2.4 GHz (Notice the copywrite date)

Working - has 2.4 GHz (Notice the copywrite date)

Another thing I noticed, was at the bottom left of the browser, on the “working” B5c’s the copywrite date is 2022. On the ones that do not have the 2.4 GHz management option, the copywrite is 2021. Even after upgrading the firmware to the latest. I’m really not sure what I’m missing here.


Hi Scott,

I’m just guessing here, but I noticed that on the pair that’s not working, you have mismatched firmware. One is newer than the other. This sometimes causes problems, but I don’t know if that’s the issue here. Also, since it’s just an x.x.x.1 update, this may not be an issue, but different firmware is sometimes an issue. I suspect it even less to be an issue since your 5 GHz worked, but it’s something simple to try.

Also, have you tried factory resetting both radios? I think that if you do, you’ll have to put the activation code in again, but it may help.

The “new” ones are on Mimosa-B5-2.11.0.1.img, both the same firmware. The “working” are on Mimosa-B5-2.11.0.img. I originally started with the new being on Mimosa-B5-2.11.0.img when I ran into the issue, and then upgraded to the x.x.x.1 to see if that would alleviate the issue. Both pairs are on the same firmware.

I have not yet tried to factory default reset, I was going to give that a shot this afternoon. I’ll update with my findings.

Side note … I have a 2nd pair of new B5c’s I was stocking as a spare. I’ve powered them up, activated, upgraded to Mimosa-B5-2.11.0.img, and the same issue. 2.4 GHz Console link is missing. Leading me to believe it’s not me, but will factory default reset and try again to see what that gets me.

OK. I brought it up because the first picture showed the remote on 2.11.0 and the local on 2.11.0.1. The 2.11.0 was pulled shortly after it was posted and there was no update for about a week or so, then the 2.11.0.1 showed up, so I suspect that there was something buggy about the 2.11.0 that was bad enough that they couldn’t even leave it posted until the problem was fixed.

Just completed a factory default reset, firmware 2.11.0, still no 2.4 GHz Console option. Could make these a bit hard to align while 60’ or higher on the tower.

Downgraded to 2.10.0, and still no 2.4 GHz Console. I went through all 4 of these, all 4 are now on 2.10.0 and no 2.4 GHz Console. These were purchased from Streakwave just a couple weeks ago. I’m having a hard time believing it’s the B5c’s with the issue, but at this point I’m stumped.

How very unfortunate … this is going to make alignment a nightmare. Wondering if Streakwave will take these back … Anyone else run into this issue? If so, what’s your alignment work-around?