2.5.0 Firmware A5, C5, C5c and C5x Has been Released!

You can read the notes in their entirety here: (There are a lot)
A5 Release Notes: http://ap.help.mimosa.co/ap-firmware-release-notes-a5
C5, C5c and C5x PTMP Release Notes: http://client.help.mimosa.co/client-ptmp-firmware-release-notes-c5
C5c PTP Release Notes: http://client.help.mimosa.co/c5c-ptp-firmware-release-notes
C5X PTP Release Notes: http://client.help.mimosa.co/c5x-ptp-firmware-release-notes

A ton of Quality of life changes, performance improvements and UI improvements. Worth checking out. This is my summary of what I find to be important to me or what I have seen in the forums as important to other people. Please feel free to comment with stuff you think is important that I left out.

A5 stuff:

  • Automatic Per Client Transmit Power Control: Transmit power per client is automatically adjusted for both the uplink and downlink in WiFi-Interop and SRS modes…

  • Throughput Improvements: MAC protocol efficiency has improved significantly to increase and balance both uplink and downlink throughput. TCP throughput performance has improved significantly as the number of simultaneous active clients increases…

  • Device UI Responsiveness. Note: This applies to the A5 and C5# lines

  • CPU Optimizations: Also for A5 and C5#. (

  • . Note: This is the same for the C5# PTP stuff. There are several other CAC related bugs, read the patch notes for full details (This bit me once, and I thought “why? Just why?” but I never complained about it. Glad someone did.)

  • Max client connections restored to 44 for SRS mode. (@Rudy will be happy about this.)

Known Issues: (This is not an exhaustive list, please read the notes)

  • A5 Radius accounting only sends Start, Stop and Interim Update messages. No data usage information is provided.

  • On the A5 client page, the Firefox browser incorrectly shows clients as disconnected even when they have been manually removed and the remove button is missing from the client screen. Firefox does not work with the Site Survey feature in the Link A5 link page.

C5# Stuff:

  • C5x Hardware Support. Please don’t try to use older firmwares on the C5x, probably a bad idea. (@Richard3 got his smaller CPE request)

  • The C5/C5c/C5x now has a single firmware image. This improves the ease of switching between PTP and PTMP client modes on the C5c and C5x. Use the Wireless Configuration -> Link Mode setting to change the operational mode, requiring a reboot. The C5x requires a feature key to enable PTP operation. Note: the C5 only supports PTMP client mode. (Narrowing down on the number of firmwares I need to keep downloaded and on various devices is going to make me curse a lot less)

  • Client Auto-Unlock in PSK SSID Mode The A5 can now automatically unlock a C5, C5c, C5x to its cloud account when using an SSID with PSK (Pre-Shared Key) security… (Heck ya, this will make many people’s lives better. READ THE ACTUAL RELEASE NOTES TO DO THIS)

  • Channel changes and channel bandwidth setting changes would intermittently dis-associate the PTP radio connection. This has been resolved. (One of the selling points for Mimosa products for me is that channel changes, besides DFS, don’t completely drop the connection, making this more reliable makes me and a lot of my customers happier)

Known Issues: (This is not an exhaustive list, please read the notes)

  • When saving the power setting on the C5c, the GUI may show an erroneous error message stating an incorrect power level. If this occurs, cancel and re-enter the desired power setting.

  • The Reset Unlock feature has been removed from C5. This is no longer required as the C5 follows the A5 regulatory domain. If the C5 needs to be “re-locked” please use the factory reset option.

1 Like


thank you for the new firmware! I have some issues with it:

  • I installed it on the near side first and although it was connected I couldn’t upgrade the far side.
  • one of my device had 73C temperature after some hours (outside is about 0C) and the cloud disconnected. After a reboot everything is normal.
  • some devices upgraded and connected to the cloud but it shows the old firmware version

I could measure some bandwidth increase after upgrade :slight_smile: - good job!

best regards, Gabor


First off, thanks for the report, good to hear.

  1. Always do the remote side of a PTP (heck, PTMP link as well, probably any though I am not sure what others there are, MPTP?) Link first, will save you a lot of windshield time.

  2. That temp issue might be a real problem, if it occurs again I would pull the .sup file from the radio before rebooting (or enable remote logging) and have a chat with Mimosa support.

  3. I thought I saw this as well, I will be doing some more broad updates tomorrow and see if I can duplicate the issue, if you see it again and I see it maybe we can chat with Mimosa and let them know. 2 reports is always better then 1.

Hi all,

I think the firmware notes say this, but always upgrade your remote side first. This is especially important with 2.5.0 because of a number of changes.

Radios should be ok up until 110C, but thanks for the info. Please let me know if your issues continue.

After doing some of my clients and A5c upgrades I have noticed a few extra features that were undocumented, or at least I missed them in my readings of the 2.5.0 patch-notes.

Under Firmware on the A5 there is a new option “Client Association Watchdog Reboot” it’s helpful note says:
Enable - OFF or ON. By default, this setting is set to OFF. Once enabled, this Watchdog monitors the clients connectivity, and will reboot the A5 when all clients are disassociated for a given time period.
Time - Choose between five and 60 minutes to set the time to monitor before initiating a reboot.

Under “Notifications” there is now a “Cloud Notification” option. (With Corresponding System Traps)

Please comment if you find other changes that you think are interesting.

I am unable to log into a c5 after the update, all other are ok. I am not using vlan management and the unit is set on static. The unit seems to be operating fine.

Have you tried initiating a reboot through the A5’s UI? (Under Clients and on the right side, you can kick or reboot the device in question)

If that doesn’t work you could try doing a hard reboot by pulling the plug.

Otherwise it could be some sort of networking issue, might have to try rebooting the A5…

Honestly, today all of my suggestions have been “reboot it and see what happens” so take what I say with a grain of salt…

Yes I have tried the reboot from the A5 I will try to do a hard reboot tomorrow and I hve rebooted the A5 also. Another thing i notice is 2 different A5c have massive different temps, one is 70f and the other is 108f.
The 70 is under use and the 108 is at idle its abou 25f outside.

I would take the temp question to Mimosa support. Could be something is goofy, but I have not seen many temp questions, if it ain’t melting I tend to leave it alone… Especially when it is freezing cold out side.

Can you ping the C5? And/or do you have any other kind of monitoring going on the C5? Mimosa cloud, SNMP etc…

yes I can ping the unit, i will keep a eye on the temp to see if it ever fluctuates

Sorry I cannot ping the unit I had the wrong ip address lol. Been a long day

LOL :wink:, I know what you mean, I am redoing our network monitoring and NetXMS has sooo many options.

Thank Goodness that Mimosa has been working on SNMP support.

Good luck! I am off to play some poker… I mean, loose money to a bunch of old farmers.

“Client Association Watchdog Reboot” is a welcomed feature although a bit dissapointed as this is just a workaround instead of a real fix for the issue it “solves”…

Interesting, can you tell me more of what kind of bandwidth increase you are seeing, what mode, how many clients etc? I did’nt notice any throughput increase in SRS mode which is dissapointing.

Hi morris,

these are ptp links.

best regards, Gabor

Just as an FYI,

If you are running United States Licensed on your A5/A5c the frequencies 5.925 through 6.200 GHz are available to be used.


If your A5 or A5c uses Auto Channel or has a DFS event it may use one of these frequencies automatically without warning you. This could get you in hot water.

Supposedly 2.5.1 fixes this, but I have not been able to test this on any of my United States Licensed A5s yet.

In the meantime, I would recommend that you manually exclude 5.926 through 6.200 GHz. You can do this in the menu for your A5 under Channel & Power >> Exclusions & Restrictions. Make sure you add and save the configuration. This will not cause downtime unless your A5 is already using a channel in this range.

Ok I did some more testing on my problem after the upgrades and not being able to log into the clients.

Let me tell you how my network and the A5’s are setup. Im running a flat network and using 3 vlans for the client data but my management is on the flat network and not going through vlans. So from the A5 I give the client what vlan they need for what IP they will be getting on. So v100 will be cgn, v200 is public static, and v300 is dhcp public. Before the upgrade to 2.5.0 I was able to log into the clients from the flat network management and If my memory is correct I ungraded from So when I set my clients up with the install app I give it what management ip address needed, so as long as it is still in bridge I am able to login to the unit but as soon as I give it a data vlan I can no longer login into the units.
I can ping some units from the A5 but not all of them, but all of them have data network access. Like I said I was able too before the upgrades.

Anybody ran into this yet? BTW I upgraded to 2.5.1 and still the same.

Thanks, Craig

I don’t run VLANs (yet) so I can’t say that I will be of much help, but who doesn’t like the blind leading the blind?

I am guessing that you can still access your clients from their respective data VLANs?

@William5 All the vlans are public ip except for v100 that is the cgn network aand I have not tried using my network card in the respective vlan to login to the unit but will give it a shot but Im not sure if i could access them using the non vlan management ip address .
What I did do on one client is set data to v300 ( public dhcp) and set the management vlan to v100 (cgn) and I am able to login to that unit fine.