A5 14 - Bad Satellite Signal

We have an A5-14 that has started reporting “Bad Satellite Signal”. When I go to the location menu, it shows no satellites and this message about the mapping “Google Maps Platform rejected your request. The provided API key is invalid.”

We are running V 2.3.3.

The last time this happened, a reboot fixed it. Not this time.

I would recommend updating to the latest firmware.

Otherwise you may be experiencing GPS interference.

The problem with upgrading to the latest firmware is the ongoing issues with DHCP and our mikrotik routers. Since there has been no update in a long time (years?), we can’t really make the upgrade without a major investment in resources.

I don’t think it is GPS interference as we have another brand of hardware at the bottom of the same tower with no GPS problems.

I am running Mikrotik’s in my network for handing out DHCP and I don’t see any issues and am running the latest firmware on all my A5©s. Are you running in SRS or Interop mode?

Thanks for the feedback William.

We are running in SRS mode on our A5s and an A5C.

We have MIkrotik’s from Hex up to an RB3011 connected to the A5s. All Mikrotik’s are running the latest firmware within 4 weeks.

We are open to making any changes necessary to fix the ongoing issues.

Huh, I don’t have the time to keep up with Mikrotik besides security issues or if there is a feature I really want. So props to you there for being on top of your network like that.

Are you using DHCP for any of your antennas? Does that have issues?

I can export one of my tower’s DHCP config, but it’s pretty much just the auto config except I put any customer the DHCP server doesn’t recognize into a list of IPs that don’t go anywhere until we manually configure each DHCP listing. I honestly only use DHCP for customers who reset the static assignment in their router so I don’t have to walk them through the setup/have to make a truck roll.

If you want to describe your DHCP system I might be able to duplicate it on my test tower and see if I can see your issue.

We just have a batch that updates our Mikrotik routers weekly. Same with backups. We haven’t had a single update cause any problems that affected our network… that we noticed.

Our DHCP is very basic as well. We have everything set up through Winbox.

  • On the DHCP tab We have the name, interface, lease time, address pool name and Yes add to ARP
  • On the Networks tab, we have a /24 subnet under address, a gateway and 3 DNS servers.
  • No options or anything else set.

We have one AP running and another 2.3.3 (with the bad satellite signal).

I’d have to go back and figure out what combination of things worked and what didn’t we had issues with customer routers getting IP addresses. We have C5’ with firmware ranging from 2.3.3 to 2.4.1

We stopped updating firmware on the A5s and C5s because it seemed that every time we did, it created truck rolls to multiple clients and pissed them off. We are gun shy. The one C5 running 2.4.1 is at my home so that’s an easy one to test with late at night.

I don’t use the “Add ARP for Leases” option, I just let the customer routers pop up in ARP after they get their address. (Not an expert in DHCP, but we don’t use it and it seems to be the only big difference between my setup and yours)

Note: Technically I only have 2 DNS servers setup in DHCP, but I do have an NTP server set as well. Here is my DHCP server config: