A5 SSID "type?"

What is the meaning of

“Type - This field is shown in the 5 GHz band. Select Fixed/CPE (fixed clients), Hotspot (mobile devices) or Trunk (intranet bridge) to define the type of clients that will connect to this SSID. Different VLAN configuration fields will appear based on selected type”

I have my A5’s set for Fixed/CPE. I run 3 VLAN’s across the A5/C5 links.

On One A5, after recent power outage, all CPE’s reconnected but only 1 of the 3 VLAN’s was reachable. I was running so after a few hours of head scratching I upgraded to and still had a problem. Getting desperate I switched the Type to “Trunk” and all three VLANs became reachable again.

The rest of my A5’s are still running “Fixed/CPE” and all VLANs are reachable… but I get the occasional call about the Internet ‘stalling’ when the customer is using it.

What is the correct setting and why ?


It looks like this one might be an @Mimosa Question/Answer. I am curious as well, another guy was wondering if the A5c could do what you are doing a couple days ago. Kinda sorta.

From looking at it, you probably want to go with the trunk option. You are already tagging and untagging your traffic from the sounds of it, your C5s are not doing the tagging and untagging so I would go with “Trunk”. If you are expecting the C5s to do the tagging/untagging then you probably should do the “Fixed/CPE” then some testing is in order to figure out how the tagging/untagging works.

Either way, if you could post your experiences and your setup (an instructional maybe?) would be awesome, this is getting to be a popular topic.

This setup is a Resort using A5/C5s to connect the buildings that cannot be reached by fibre. Each condo gets 25x10Mbps. The setup at the Headend is a Mikrotik CCR fed by a 500Mbps Fibre transit. Behind that is a Netonix 24 Port switch which is doing the distribution layer tagging.

3 VLANS are trunked to each building. 1 Data (wifi in each room), 1 VoIP and 1 for Management. The VoIP and MgMt VLANS are the same across the entire site. The Data VLANs are different to each building in order to facilitate QOS, or at least Rate limiting to each building/condo. E.G. Building 20 would have VLANS 20,99,100 Building 22 would have 22,99,100 So on the Netonix <-> A5 link there are 8 VLANS trunked to 6 buildings feeding 40 condo suites.

Each C5 trunks the respective VLANs to the Netonix in that building, which then trunks the Data and VoIP VLANs to each phone, The phones strip the Data VLAN tags and pass the Data packets to the Wifi routers that are plugged into them.

All Switches, C5’s, and the A5 are on the Management VLAN. When this broke after the power outage all devices on the MgMt VLAN were reachable. Traffic on the Data and VoIP VLANS was being received at the Mikrotik router port and the router responded. Traffic was seen leaving the Headend Netonix but was not seen in sniffer captures at the Netonix behind the C5

So it looked like bridging was broken inside the A5.

What makes no sense is that it was originally setup 6 months ago on 2.4.0 and worked fine with the Fixed/CPE setting. It was upgraded to beta-1, 3 weeks ago and was still fine until 3 days ago when the power failed only at the headend.

1 Like

Sweet, thanks for the overview. I hope Mimosa gives us an answer as to what is the proper settings and why you were not able to keep things working.

You might try swapping one of the other two buildings over to the “Trunk” Mode, during some down time, just to see what happens. I would bet that because you are trying to use the link as a trunk as in this picture:


You should be using the “Trunk” setting, that it is working under the “Fixed/CPE” setting seems unintended/lucky.

Hi @ian1,

If it is your VLAN and you want the A5 to just pass everything thru (e.g. he has a router behind the C5 and behind the A5 and you’re doing your own VLANs), then the A5 should be configured to be a TRUNK. If you want to take advantage of the A5 adding its own VLAN tags for traffic from the C5 to the A5, then the A5 should be configured to be Fixed/CPE.

1 Like