A5c Performance Issues with 100+mbps Plans

We are seeing strange performance issues when using the A5c with any of the C5,C5c,C5x clients on 100mbps plans.

Our setup is as follows:

APs (in SRS mode, 40MHz channel):
Setup 1: A5c w/ 2 RF Elements 90° Horns
Setup 2: A5c w/ N5-360 Omni

Clients:
C5, C5c and C5x
(I am aware of the 100mbps max base license on the C5x)

We have a total of 5 APs deployes with the RF Elements horns and another 2 with the omnis. Each AP only has one or two customers on them so far, with one hosting 6 clients.

We are definitely not saturating the user load on these APs with the above numbers. Most customers are also within 300 meters of the APs.

We set our clients on 30, 50 and 100mbps speed plans. We only have one client on a 100mbps plan so far, the others are all on 30 or 50.

The majority of the clients are connected at MCS 9/9, with a couple bouncing between 6 and 7 on the rx.

Everyone on the 30 and 50mbps plans are working fine and speed/throughput testing shows these speeds are being attained. However whenever we set a client on a 100mbps plan (MCS 9/9) we are getting a max of 70-75mbps download when running various speed tests, iperf tests and Mikrotik Btest’s. When I set up both a test C5 and C5c to a 140 or 200mbps plan and connect to any of the APs, I see 100mbps and 160mbps accordingly, but never get my full speeds for the plan.

Has anyone else seen issues when using 100mbps plans or above using C5 or C5c radios connected to an A5c?

I havn’t sold any plans, but in testing I saturated a 40 Mhz link with ~200 Mbps… That said, I would check you bandwidth limiter and see if it it’s actually catching the speeds correctly. (If I am reading you correctly, you tested 100 Mbps and saw 70 Mbps and then tested 140 and got 100 Mbps)

1 Like

Yep, that’s correct. A 100 plan yielded 70-75 in speedtests, 140 yielded 100, and 200 maxed at 140. The only bandwidth limiter is what is set for the plan in the AP for that client. This does not happen on our 30 and 50 mbps plans, they test out correctly.

OHHH…

Ya, I don’t use the bandwidth limiter in my A5s, we do all of ours in the router at the tower. (Mikrotik)

Hrmmm… What does the AP say as far as throughput when you are testing? How are you doing the speed testing? Have you tried iPerf? That is how I really test a connection if I am wanting to push things…

1 Like

Did anyone ever find a solution to this? In SRS mode running iperf per Mimosa suggestion, we can never exceed ~100Mbps when testing with an 80Mhz channel and link of 867/867. We have factory reset the AP and reconfigured with no Traffic Shaping Plans to test and the results are always the same. This has been confirmed on multiple AP’s all with gigabit capable feeds, client equipment and even test laptop.

@Ryan15, how are you doing the test?

We have done tech laptop plugged direct to C5c PoE injector running both our own Ookla speedtest and iperf. Both test server are connected in our infrastructure core which is connected via our own switching gear and fiber with 10G uplinks. Same test systems are used to test 1G+ connections with correct results.

In the process of setting up a lab A5c and C5c to test between firmware versions and wireless protocols.

Which of the “C” devices are you using?

We only use the C5c’s.

What channel size are you using?

I guess you are seeing the same characteristics that the other guy did? MCS of 9/9, 40 MHz wide channel (or wider, on clean spectrum) and all the rest of it?

We see it both on 40Mhz MCS 9/9 and 80Mhz MCS 9/9. Seems to be no different. However I can note if we drop a traffic profile lower than 100M, the change shows instantly so the traffic profile work, it just seems there is some unseen hard limit of 100M because we see no latency change, etc. when testing.

Weird, sounds like it could be a software deal.

I would setup a computer that has access to both sides of the link and an internet connection, then give Mimosa support a ring. (Orange button on the bottom right of the screen that says “Chat with us”) Those guys are right next to Mimosa’s Engineers and will be able to hunt down the issue.