B11 POE power supply

I want to share an incident that happen with me, I unboxed my new Mimosa B11 link, looks great, I powered it up, I could connect to the wifi management, however couldn’t reach to the link through the LAN cable,
The link connected both sides, but still the ethernet LAN port couldn’t ping the IP links?
I switched the Mimosa POE (50 watt) with another 48V POE(60 watt from ubquiti), and it worked!
The cable I used is 23AWG CAT6. ran for 40meters.
I felt bad! it is a brand new link, mimosa has some room to improve here, I had to pay for the new ubquiti POEs,


Sinan, do you recall the state of LED on the Mimosa POE injector in question and if you are able to power up any other devices with it? Please contact our Support team via our live chat line at http://support.mimosa.co

The LED of the POE injector lit up(can’t recall the color,)
The LED’s of the B11 lit up(the power and wifi)
I was able to login through the management wifi.
The ether port didn’t work, and when I connect it to my laptop port I got (cable not detected) as status of the ether.
I think there is no enough DC to make the ether chipset work, but it is enough for the radio and wifi to work.

Kind Rgds

I had last week same issue but with a B5 Pair, only 1 of the poe injectors ethernet port worked!
I purchased an extra POE injector im waiting to receive it to send the other one to rma.

We had the same issue with B5c

This reminds me of the issue my boss has with some Mimosa radios. He uses a MacBook Air with a USB 10/100 dongle. He cannot get an ethernet link to several Mimosa B5s or B11s when trying to configure them on the bench with the supplied power supply. Some work. I can pull the cable from his adapter and plug into my 2010 MacBook Pro’s built-in ethernet port and I get a Gig link. We’ve been blaming his USB adapter.