B5 first use unboxing- not able to login after unlock and software upgrade!

I can get to the GUI page. Askes for password only- tried the usual suspects to no avail. There seems to be no physical reset paperclip.

These are brand new from box. I created an account and unlocked- received an unlock code- now I want to start to program but can’t log into the radio.


The only SSID available is AP-####. And that WiFi network is password protected…I’ve tried all the usual passwords and all fail to connect to the B5 when put in stand alone mode.

Newer radios don’t have a 2.4 WIFI ssid. You need to follow the directions here: Backhaul User Guide: Reset B Series Radios without 2.4GHz Functionality

Dustin, that didn’t work. The ARP entry fails. Access denied. I’m in CMD with admin mode.

This is crazy. This is a pair of brand new radios. I’m getting frustrated

I can Not, nor have I EVER been able to reach the stand alone GUI page even though I set my laptop to that network and I get ping replies from the GUI will not load.

If I power the radio through my switch, the radio will get DCHP and i can reach a GUI page that simply asks for a password- no user name of setup page- just asks for a password with a big mimosa logo. Then after five attempts at guessing the password- it makes me wait 60 seconds in between attempts.

I recommend talking to Mimosa Support. They can either walk you through the process or they may even be able to do it for you through a screenshare. Mimosa Networks