B5c Error "Unable to Reload Data Please reload"

Did anyone experience this? Please do help… Its brand new B5c Having this kind of error, it is my first time to encounter this…

Glad to here any suggestion to resolve this matter…

Just guessing here, but right offhand, that appears to be a web/browser error.

  1. Try the browser in Private or Incognito mode and see if it works better. If it does, there may be something in the cache that’s causing a problem.
  2. Was the unit just booted? If so, it may not have finished loading it’s web interface.
  3. Has the web interface crashed? If so, does rebooting the unit help?

Hello there, thanks for the reply, 1st there are four units i have prepared for the two links all B5c’s, this is the only one that has problem… all option have done but to no avail… incognito? done… using only IE, Chrome, Mozilla FP, Brave, Edge? done but its always the same result…

any option to reset or just clean its cache or whatever?

Incognito/Private mode brings no cache information. It’s an easy thing to try without actually clearing all the data you want out of the cache.

In that case, I’d guess something just went wrong with that one unit. Try a factory reset on it and activate it again to see if that helps. If that doesn’t do it, then you’re probably down to calling Mimosa Support.

I see this happen all of the time with these units - could be connectivity issues or just plain the units processing is behind.

Holding the “shift” key and then clicking the reload button in your browser will query the device for a new page and not use cached data.

This does not always work - and I seem to see this on the B24’s the most when aiming them. Seems to be across all Mimosa devices - it just happens sometimes - then it goes away.

If a factory reset does not fix it like @Wayne2 suggested - then RMA it.

okay i will try it now and see if i would work

Okay sir but i’ve never done a hard reset on B5c before, do you have links for guides on how its done sir?

See if this helps.
http://backhaul.help.mimosa.co/backhaul-faq-b5-b5c-device-reset

tanx sir i have tried this one also… but still having the same problem… anyways thank you for the inputs you’ve shared…

If you can get into the radio at all - there is a re-set in the “firmware and reset” page - you can re-set the unit to defaults if not then follow the guide - it should work.