B5C Ethernet problem

Hi, this is the 99999999999th thread about that i guess
We have like 10000$ of B5c with broken ethernet, and we are getting a bit tired of that because it is costing us almost more than having a licensed backhaul.
Now the question is, since mimosa refuses to even repair them, did anyone figure out what happens to the devices that develop flapping problems ( between 1000 and 100 ) and / or how to repair them?
Mostly happens after lightning storms, we have like 3/4 protections chained, composed of varistors, chokes , GDTs, and we even embedded a media converter inside the mimosa itself…
And is there a way to read cable SNR like we do on Ubiquiti AC gear ?

We are ready to replace SMD parts or whatever it takes

1 Like

i feel you bro, i have the same problem. b5c is expensive and yet it has made in china LAN PORT!

Just recently had this issue twice in the past week. Port flapping seemingly caused by the Lan port on the POE injector. Swapped injector the first time, everything was stable for about 5 and a half days, then the same issue again. Power cycled POE injector yesterday afternoon, been stable ever since (almost 24 hours since it happened). Switch logs show STP blocking the Port when the disconnect happens on the B5, then after a power cycle of the injector, STP forwarding resumes.

Again after a few days the port flapping continued, so I changed out the network cable with Ubiquiti tough cable with their tough cable connectors. The flapping continued. My last fix, which was just implemented yesterday, was to install a TrippLite Isobar between the POE injector and the battery backup it used to be plugged directly into. So far i’m at 24.5 hours without any port flapping. We will see what happens.

Too good to be true, right before the 27 hour mark, port flapping again.

2022-07-08 01:57:13 (UTC +0000) root: MIMO_EVENT ethernet link duplex Full
2022-07-08 01:57:10 (UTC +0000) root: MIMO_EVENT ethernet link up(1000/Full)
2022-07-08 01:56:58 (UTC +0000) root: MIMO_EVENT ethernet link down
2022-07-08 01:56:57 (UTC +0000) root: MIMO_EVENT ethernet link duplex Full
2022-07-08 01:56:55 (UTC +0000) root: MIMO_EVENT ethernet link up(1000/Full)
2022-07-08 01:49:58 (UTC +0000) root: MIMO_EVENT ethernet link duplex Half
2022-07-08 01:49:03 (UTC +0000) root: MIMO_EVENT ethernet link down
2022-07-08 01:49:01 (UTC +0000) root: MIMO_EVENT ethernet link up(1000/Full)
2022-07-08 01:48:59 (UTC +0000) root: MIMO_EVENT ethernet link down
2022-07-08 01:29:08 (UTC +0000) root: MIMO_EVENT ethernet link duplex Full
2022-07-08 01:29:06 (UTC +0000) root: MIMO_EVENT ethernet link up(1000/Full)
2022-07-08 01:29:04 (UTC +0000) root: MIMO_EVENT ethernet link down
2022-07-08 00:17:17 (UTC +0000) root: MIMO_EVENT ethernet link duplex Full
2022-07-08 00:17:14 (UTC +0000) root: MIMO_EVENT ethernet link up(1000/Full)
2022-07-08 00:17:12 (UTC +0000) root: MIMO_EVENT ethernet link down
2022-07-08 00:16:45 (UTC +0000) root: MIMO_EVENT ethernet link duplex Full
2022-07-08 00:16:42 (UTC +0000) root: MIMO_EVENT ethernet link up(1000/Full)
2022-07-08 00:16:40 (UTC +0000) root: MIMO_EVENT ethernet link down
2022-07-08 00:16:06 (UTC +0000) root: MIMO_EVENT ethernet link duplex Full
2022-07-08 00:16:04 (UTC +0000) root: MIMO_EVENT ethernet link up(1000/Full)
2022-07-08 00:16:02 (UTC +0000) root: MIMO_EVENT ethernet link down
2022-07-07 23:48:09 (UTC +0000) root: MIMO_EVENT ethernet link duplex Full
2022-07-07 23:48:07 (UTC +0000) root: MIMO_EVENT ethernet link up(1000/Full)
2022-07-07 23:48:04 (UTC +0000) root: MIMO_EVENT ethernet link down
2022-07-06 20:58:58 (UTC +0000) root: MIMO_EVENT Reboot reason: Power On Reset
2022-07-06 20:58:54 (UTC +0000) root: MIMO_EVENT Shutdown reason: Power On Reset

Replaced the B5 unit with the port flapping issue one week ago today, have not had a single drop since the swap.

Will monitor for another week to be sure before trusting it to be back in production again.

Thanks for the info man. I appreciate your sharing with the community.