B5C is There any hero solve this Problem "link down ethernet"

i need a talk about B5C Its Nice Product but the same Time its Have poor Ethernet interface
the issue “link down ethernet From 1G to 100 some times 1G to 10Mb !!” i read and i read and read , but all way i Failed.

What have you checked and tried as far as fixes?

Cabling, PoE injector, device you are connecting to, tried connecting to another device? Will help to guide diagnostics.

all your mentioned "Cabling, PoE injector, device you are connecting to, tried connecting to another device ", i am did it , but doesn’t fixed


Did you see any changes to how things worked when you made changes?

Is your overall cable length to the B5c over 300 Meters?

Is there a possibility of noise coming from the area? Electrical to be specific, AC motors, FM radio transmitters, anything with a lot of power and little shielding?

If not, then it’s probably time to contact Mimosa Support and see if they have any recommendations for you.

Where is it connected to,a switch?which model specifically?

switch tb-link 1g , mikrotik 3011 ,4011

Try a switch that has direct ac with ground power connected to it.I had the same problem with the b5.Had to use a mikrotik rb1100 and it stopped port flapping.

@ibrahem Try to switch between: Master / Slave Mode:

Selects master/slave mode for Ethernet Interface: Auto, Manual Slave, Manual Master, Preferred Slave, Preferred Master. The Manual Slave option improves interoperability with some routers and switches. In my case, the Manual Master solved my “link down ethernet” problem.


Try to check if power injector is well earthed. Poor earthing causes Ethernet to flap

Idem, with switch Cisco poe SG250, with manual master and ground : B5C end flapping