B5c Speed Test Not Working

Links have been up a week and we went to check the bandwidth using the built in test, and it starts but never ends. We have to cancel the test for it to stop, and then there is no results. We have tried to change the time, and type of test, no change, fails the same way. Any ideas?

Same here. Different browsers produce same result. FW 1.3.1

We are running 1.4.1. Interesting when I wrote about a polarization issue, Mimosa responded within hours then closed the thread before I could comment. now, there is silence on this. Since this now appears happen in a earlier release, looks like they know about it. MIMOSA, this is a important feature, a game changer for me in future purchases. Please comment.

Hi Dan,

These posts are the first that we heard about it, and we are testing it in-house to replicate. The bandwidth test depends on communication between local and remote radios. One side sends a command with a start and stop duration to the other side. If there is loss in communication between sides either due to RF or network configuration issues, then this could happen. We’ll post here once we understand what might be happening.

I think there is something to do with uptime. I’ts not important feature for me, but i see this happen after 1month uptime. BTW, my links are with steady rates and very good signals. This 1.3.1 one i had to downgrade and i have written about my problem here.

Thanks Chris. If you need to look at a link, I can arrange that.


Hi Dan,

That may be useful later. For now, would you please send your support files (.tar) from both radios to support@mimosa.co so we can take a look?

I am having the same issue. @Dan4 I must be blind, where do you see device uptime?

Well my mistake - actualy is link uptime, but never disconnected - on the top

@Nikolay Thanks for the clarification. I think it is actually device uptime that causes the problem. I am tweaking the link frequently so the link uptime was only a few days but the device uptime was much greater. After rebooting both sides I am able to again run the speed test.

Hi guys. I am experiencing the same problem with my B5Cs. Can´t run the bandwidth tests, or at least they seem to run, but results are never displayed. I am in FW version 1.4.4. Any update on this issue? Thanks in advance.

This bug has been difficult to replicate and is relatively uncommon (4-5 reports and problem goes away after reboot). In the past, we made some diagnostic firmware available to users that reported it, but unfortunately, none of them were willing to install the firmware at the time. That firmware is now deprecated, so we don’t recommend installing it. The root cause could have been a memory leak, or an RF problem where the remote side did not receive the test start signal from the local side.

Hi Chris,
this problem is common and is replicatable for devices that have over 30days uptime.

Hi Nikolay,

If you have a link that displays this problem, please share it with Support so that we can have a look. We have not been able to replicate this on our own network, and very few users (4-5) have reported it.