B5c unable to load data. Please reload

So I bought two B5c’s. The first one I successfully updated it’s firmware and configured it. The second one after unlocking the device when I open up 192.168.1.20 it won’t even let me update it’s firmware and tells me “Unable to load data. Please reload.”

Try using the browser in Private mode. There may be some left over data from working on the first unit.

It still didnt work. Tried other browsers still not working.

I just want to verify that you don’t have both units, both of which have the same default IP address, attached to the network at the same time before changing the address on the one you’ve configured.

You may also want to try swapping power supplies in case the one for the 2nd unit isn’t putting out quite enough power for it to work correctly.

One other thing to try would be to factory reset the unit you’re having issues with.

Assuming you’ve done everything the same as with the first unit, plus tried everything mentioned above, then I’d recommend calling Mimosa support.

1 Like