C5 won't update newer than 2.0.0

I had a C5 fail and when I’ve pulled 2 replacements off the shelf that I’ve had (new in the box) for a long time. They “required” a firmware update right out of the box and finally got 2.0.0 to load with Mimosa support. I cannot get any upgraded firmware to load. Always get invalid image file error. I’ve tried 2.2.3, 2.3.3, 2.4.1 & Have tried rebooting and then attempting to load but with no luck. Anyone know of an interim version I need to jump to between 2.0.0 and 2.2.3 or any other words of wisdom?

Try mobile app, some old radios may require an interim firmware. It should handle it. You will need a G2 to work it though.

In the Firmware Patch notes, there is a note that says:
C5c PTMP and C5c PTP are not compatible. C5/C5c can be upgraded to 2.4.x-PTMPfrom 2.0.0-FCS and newer.Older releases must be updated to 2.0.3 for A5 and 2.0.0-FCS for C5 before moving to 2.4.x-PTMP. Out of box C5s may have 2.0.0-beta loaded which must then be upgraded to 2.0.0-FCS before upgrading to 2.4.x.

I don’t see 2.0.0-FCS in my firmware downloads, but if you contact Mimosa Support you may be able to get a copy. Contact me back if they can’t and I will reach out to the people I know to see if there is another way to get 2.0.0, which is why I keep a local copy of every firmware I have ever used, always something that comes along to bite you in the butt.