C5c and C5 not recognized on my network

I am testing my equipment in our warehouse for training before deploying. We have a C5 connected to a G2 on one side of the room and a C5c connected to a G2 on the other. All equipment has been unlocked with codes. I want the C5c as PTMP for the time being. With this setup, I can only see 1 G2 via WiFi which is the one connected to the C5. The G2 connected to the C5c lights shows it is online and the C5c lights shows it is online but I am not able to communicate with them. When I check my network on Mimosa, it shows I have a C5c and C5 that have never connected to the Cloud.

I have tried resetting all devices to default and direct connect to configure. Again, only one G2 will let me get to the dashboard screen. The other G2 will not accept the default password. When connected to the one G2 that ‘works’, I am not able to communicate with the C5. Even putting the C5c on the G2 that “work”, I still can not communicate with it. I also tried adding the ‘non-working’ G2 manually and it shows as ‘Failed to Inventory’ with ‘Unknown serial number’ as the reason. I am not able to do anything other than delete from inventory with it.

Could someone give the ‘Step-by-Step’ of how to setup a test platform as well as how to ‘see’ all devices on the ‘Manage Your Network’ on my Mimosa account. I would like to make sure the equipment works and my tech know what to expect BEFORE deploying in a live network.

Hi @Franklin,

If both of your devices are in PTMP mode, they will never communicate to the cloud unless you have an A5 or A5c in play. The C5/G2 only communicate to the A5 and then the A5 is the device that actually reports to the cloud.

If your C5c is in PTP mode, it has no way to communicate to the G2, which is probably why you can’t communicate between the G2 and C5c.

Please keep in mind that the C5 will never work as a PTP radio, which means it’ll never be able to connect to the C5c (if that’s what you’re trying to do).


Also the G2 is only meant for PTMP devices (C5, C5c, and C5x) and definitely won’t communicate to the cloud if you’re trying to use them in a PTP situation.

So here’s two examples of setups that should report to the cloud:

  1. PTMP Setup
    Router/Switch connected to the Internet —> A5/A5c —> C5/C5c/C5c (in PTMP station mode) ----> G2

  2. PTP Setup
    Router/Switch connected to the Internet ----> Mimosa PoE ----> C5c/C5x (in PTP Access Point mode) ------> C5c/C5x (in PTP Station mode) -----> Mimosa PoE ----> Computer/Switch/Router


Thanks DustinS. I did not account for the A5c broadcast. We had an extra A5c in the warehouse, connected to the test network and now we see the devices.

1 Like