C5x Fallback Address on 2.8.1

The fallback address of 169.254.200.20 no longer responds on v2.8.1 for the C5x. Logging into the admin page, I see it has a random address, example:
IPv4 LLA: 169.254.58.14

Generating a random address completely defeats the purpose of having a static fallback IP that you can connect to. When the C5x connects to the AP, it gets a random IP that I don’t know. The fallback was the only way to connect to the radio while installing a new device, prior to knowing its actual address.

The release notes don’t mention this change, and still reference the original .20 IP. Is this a bug, or is there some other way to connect to the radio in a static way?

John,

I can’t answer to the change. However, when you say “When the C5x connects to the AP, it gets a random IP that I don’t know.” I assume you mean it gets an address from DHCP. Have you considered setting a DHCP Reservation for it? This would cause it to always get the same address. Another option would be to exclude its address from DHCP so that DHCP won’t try to give it to anything and set the IP address as static in the device. The C5x also has the option to set it to DHCP, but use a static address that you set as the fallback if it fails to receive a DHCP address.

Correct, the C5x connects to the AP and gets a DHCP address. The thing is I set up several radios for client installs, then just grab one when I head out to do the install. I don’t care what the IP becomes, it’s just a switch, so I would prefer not to setup a reservation for it. Plus I need to connect prior to connection to set location and SSID, then after connection to align. The fallback IP was perfect since it always worked. Using the DHCP + Fallback feature only works until it connects, then I can no longer access it since I don’t know its IP.

How do other people accomplish install with this situation? Do people just use static addresses?

John,
As you mention, you get into the device before deployment. You need to set the network name, device name, and other parameters. So, if you have an addressing scheme you like, while you’re there, just setting a static IP would probably be the easiest thing to do.

In the network training I’ve had, servers and network devices are usually static IP addresses. If you have DNS running and set the DHCP server to register all leases in DNS, you might be able to reach the device by name; but again, you have to set a unique device name. If you’re making entries anyway, you’d might as well just set a static address. This should only be a problem if you need to change your addressing scheme because it would require getting into each device to change its address as opposed to just disconnecting or rebooting the device.

@DustinS, would you know anything about this?

So while I was unaware of the 169.254.200.20 address leaving, you can use two other methods to access the radio.

  1. mDNS address - the address for each radio would be the following: device-####.local. The #### would be the last 4 of the serial. You can see an example in the screenshot here: Client User Guide: Device Details

  2. You can use the IP address the app uses to communicate with the C5. 207.89.26.237. You would need to set your laptop to 238. Subnet is 255.255.255.248.

I would suggest trying method 1 and only using 2 as a last resort. I will check with engineering on the 169 address, but there should be no reason why it doesn’t work.

1 Like

So I confirmed with engineering that anything running 2.8.X will not have the 169 address since they introduced the mDNS address for devices.

John,
Do you know the IP of the AP and can log into it? If so, on the Dashboard page, scroll down to the bottom and it will have the IP address of the remote station. Click on that IP address to be taken to it.

This works with 2 C5x in PtP mode. I’m not sure what shows up on the AP when it’s in PtMP mode. Does it list all of the remote devices it’s connected to?

I am trying to use mDNS, but this doesn’t seem to work for me either. To give you a you a little more detail about my install system: I use a mikrotik mAP router that provides the POE power (from a battery) for the radio, my iPhone connects to the mAP in order to access the device. I have a DHCP server on it that serves up 169.254.x.x addresses so my phone can access the C5x without routing (iPhones will prohibit requests that route into a 169.254.x.x network, so it must be in that network). It does not appear that Mikrotik supports multicast dns, so this is essentially impossible for me to use. I will play around with the config a bit, see if I can make it work, but the mikrotik forums are nothing but complaints about mDNS.

Can I ask what was the intended design consideration for mDNS, how do you expect someone to connect with it out in the field? In my area, we have to install the majority of our SMs up in trees where I don’t have access to power. So a small battery operated router is my only option when 60ft up in a tree.

Well, to my understanding, mDNS shouldn’t require anything besides Multicast support, which Mikrotik has had for quite a while.

Probably you should look at this page on Mikrotik’s forums that explains how to enable mDNS in RouterOS (Or just connect directly to the antenna as I have my techs do, personally I prefer to VPN into the AP because that’s just easier IMO)

Note, you need to scroll down to post #29
https://forum.mikrotik.com/viewtopic.php?t=105651