C5X PTP Issues Throughput drops/Diff Signal Levels

I have a 1.5km PTP Link using a pair of C5X and my throughput is dropping randomly - i noticed that my AP and my STATION are reporting very different signal levels when this happens. When the link is stable both sides report 57-59dbm but when my throughput drops my AP reports 5-10dbm lower than my STATION Side. I’ve already tried changing frequencies and i also checked the combined spectrum to make sure that i selected the cleanest frequency possible.

Please help.




PHY TX RX should match, lower the power for that distance

Lowered my power all the way down to 8dbi on both sides, even tried switching to 40mhz but for some random reason throughput still drops every few hours.

This is my TX/RX from the last 24hrs on 40mhz

That sounds like interference. The problem is what’s interfering? Is it other devices transmitting intermittently? Is it weather? Is it something crossing through the radio beam (flocks of birds, airplanes, etc.)?

1 Like

Not really sure what it is, but it might be a tree blocking the radios randomly?
But this is what i noticed, every time i switch channels after a few hours this is what appears on my spectrum. Don’t know, maybe a random radio left on auto or something? If you check my first post that wasn’t there 4 days ago.

wierd interference

Might try to elevate the station side a little more. Station side is only at around 30-40ft.

Yes, I see it’s not there in your first post. Does the timing of this correspond with your signal drop? That may be hard to tell, though. It shows when you’re in the system, but I’m not aware of any way to log this to compare the two. So, you’d have to time it just right to catch it.

Yes I’ve noticed that every time my connection drops this random interference appears on the spectrum scans, at first i thought it was me causing the noise - maybe the power of the radios are too high so i dropped it down lower and lower and then still, it happens.

I don’t get fully disconnected my signal stays on 57-59dBm but my throughput drops down to 30.

the same problem of my ptp c5x devices after upgrading my firmware from 2.8.4 to 2.11.01… PHY Tx/Rx (Mbps): 30/520. i just fix it by flashing back the old firmware

I think I got mine working fine now, I disabled Auto TX Power and set the EIRP Manually(had to fine tune it, by doing a little trial and error setting it on diff power settings and checking what is the most stable.

My PHY Rate is now around 650-800.

1 Like

Thanks for the feedback Kristian. I was watching this post closely, as I’ve experienced the exact same issue on a 5KM C5x ptp link. Already replaced network cables, PoE adaptors, changing channels with no joy. Every other minute, the signal drops, then throughput drops to sometimes kbps, and after10seconds, throughput return normal again.

I’ve taken your advise and manually set the TX Power and set the EIRP Manually (currently on 41/21 dBm). So far so good. What power setting worked for you?

Thanks for your post, greatly appreciated.

I only have a 1.5km link but my power settings are:

Antenna Gain: 16dBi
Tx EIRP / TX Conducted dBm: 38/22

I am also using the 25dbi Dish Antenna.

Also if you wanna do your own trial and error on your setup, you can check the logs on Mimosa Cloud - I think it records the radio activity for 24hours.

1 Like