DHCP issues on firmware 2.4.1

After upgrading one of our A5 AP’s and C5 clients to the firmware 2.4.1, DHCP is not working properly.
DHCP is a Mikrotik router. A5 configured with static IP and C5’s with DHCP (C5 is in wireless client SRS)
Anything past the C5 client such as a home router keeps losing pings to the AP. Unplugging the C5 from power for over 30 seconds and plugging it back in sometimes resolves the issue. However, if we reboot the C5 without power cycling will bring back the disconnection issue.
A temporary fix was to set both the C5 client and the home router connected to the C5 to a static IP
Is anyone else experiencing the same or similar DHCP issues?

I do not have 2.4.1 on the sector I can test on, but I have a friend who has a C5c on 2.4.1 and the A5 is on I just used him as a test and his ASUS router got a DHCP address from my Mikrotik router through his C5c which I switched from Static to DHCP. All seems to be working, I restarted the antenna and both it and the router behind it received DHCP addresses. I’ll see if I can update the sector tonight and see if we can duplicate the issue.

Hi @Abe,

I have made forwarded this on to the support manager, Hector. He should contact you soon with a case number so we can follow up with you.

Hi @Abe, we have created a case for you and you should’ve received an email from Mimosa Support.

1 Like

So this is still a problem. What is the status on a fix? Tons of people have to stay on 2.3.3 which is ridiculous.

Have you tried with

I have tested DHCP to the C5, to the Client’s router and neither have had issues on 2.4.1 or I am using a Mikrotik for my tower router (Mikrotik Router > Netonix Switch > A5c > C5c > Asus Router), I do not have Option 86 enabled (I do it in my firewall). Otherwise my network is pretty simple. Both C5c and other C5s get DHCP addresses readily and so do an assortment of routers, but normally I run everything as static.

Yes we have tried

There are numerous brands of asus routers that does not work on but works on 2.3.3. All software versions tried on the asus routers.

I’ve also seen this with some dlink.

It’s pretty crap. I’ve been pretty unhappy with how slow mimosa is to respond to problems like this, so much so that most of the network is still on 2.3.3 because we can’t change.

Random packet loss, dhcp issues. Problem after problem. Going on 2 years now.

What kind of ASUS Router and what kind of router are you running at your tower site?

Most of our customers routers are RT-N12, the customer I have extensively tested on (cause he is a friend) has an RT-ACRH13. I know I have another customer on a Ubiquiti Router getting DHCP as well they game on that connection so I would know about packet issues. If you want I can move a couple customers over to getting address through DHCP see if I get any packet loss. Though I know with statics I don’t see any special amounts of packet loss.

AC1200 ASUS routers.

The packet loss stuff is something to do with firmware. I got on a chat today with mimosa and downgraded the AP first to 2.3.3, no change. Downgraded the SM to 2.3.3 and packet loss immediately went away. This one was with a Cambium router.

There is some bad firmware stuff going on that needs a quick fix. A really quick fix.

Sorry for my Networking Acronym shortcoming, but would you please explain what you mean by “SM”? Do you mean a CPE like a C5 or C5c or Router like a G2?

I guess not a G2 because your customer is on a Cambium…

SM is a Cambium term – Subscriber Module

Sorry my Cambium is showing. SM = CPE (subscriber module)

We only have approximately 10 G2’s out, they are not a good fit for us either.

I’ve talked with Engineering about your issue. They would like to try and get remote access to this C5 so they can plug logs and do some triaging on this issue.

The other few times I’ve encountered this, it was because the customer had a bad cable end or bad cabling. 2.3.3 doesn’t care as much about cabling integrity, but it seems to be more sensitive in 2.4.1+

To be able to fix this, they need one that is actively messing up on 2.4.1+ so they can find the root cause of this issue. If you would like to provide us with remote access, please feel free to email me at dustin@mimosa.co.

Also tagging @Hector-M for visibility

The engineers already have access to the A5, C5, and a customer router and I’ve said they can upgrade and downgrade as needed to find the issue. It should all be in my ticket…

I feel like blaming this on cabling is a cop-out answer as well. We test all of our runs with our fluke cableIQ. If it passes a gigabit test then I’ve never seen problems relating to cable.

If is “more sensitive” then they should turn the sensitivity down. Replacing runs with Cat6 shielded at customer houses is not a solution.

Figures… I should have known too, was reading Cambium manuals last month. Ya, we have thought about the G2’s a couple times, but each time we decide the random metal filing cabinet placed in-front of the router would cause a brain hemorrhage or a sever bought of alcoholism for one of us. Not ideal… probably.

If you need a hand verifying what happens, just give me a setup to try out. I can’t be very quick, but I could probably try something out tonight.

I tried again to duplicate the issue last night, friends ASUS RT-ACRH13 through a C5c > A5c (N5-360) > Netonix > Mikrotik Router CCR-1009-7G-1C (only doing routing and VLAN) > A Tycon POE Switch (Not a fan, but it does have a temp sensor…) > B11 link > Another Netonix > Mikrotik CCR1009-7G-1C-1s+ (Which is doing my DHCP)

I know, kinda complicated, but that’s what happens when I am only given restrictions on IP resources and not money. :upside_down_face:

I got 1 Ethernet flap when I changed over the router from static to DHCP, 2 hours later I swapped the C5c from DHCP to static. Is this a constant issue or something that happens during load or around the time the router is re-grabbing it’s IP through DHCP?

This is a constant issue on, upgrade to it, packet loss, downgrade to 2.3.3, packet loss goes away.

We are at a point where we are ready to downgrade everything back to 2.3.3. The only feature we will miss is the mac forward table so we could see if there’s a new mac if someone plugs in a different router but the stability on is just too poor.