GPS not detected

A few minutes ago I just unpacked a b24 and one of them says GPS not detected. Radio performance may be impacted.
How I should proceed? Will it be a hardware error?
If I use it like that, will there be a loss of performance?


Well, if you were in Ubiquiti land I would say as long as you did not use the B24 with GPS issues for the AP then you might be fine. (I recall that Ubiquiti will tend to get their timing decisions from the AP.)

I would put a good copper down that the B24 does not have a “none GPS” mode, at least that is what I am gathering from the support page.

I think Mimosa uses each ends GPS to keep them in sync. I would recommend getting in touch with Mimosa support and seeing if they can get it fixed for you one way or another. If the GPS chip is bad who knows what else went south during shipping and the such.

1 Like

When you unpacked it were you near a window or somewhere else that the unit could SEE the sky for GPS?

I have 2 that for no known reason randomly drop GPS… there’s “nothing” to block GPS from getting to them either… they just show no GPS detected, than hours or days later they’re working again with no intervention.

For function, since I’m not using the GPS for co-location reasons, I have not shown a loss in performance despite the message. Since I don’t need GPS for co-location it’s a non-issue in that aspect.


It’s hard to say what the issue is. If you’ve just taken it out of the box and you’re indoors, I would say it’s probably what @arthur mentioned.

@Bryan1 this could be because of LTE collocation interference if you’re on a tower with LTE.

Alas, we’re on our own towers, and there’s no towers nearby… Unless they’re in full cammo! Where we are — you can see towers for miles around if they exist more than 50’ up…

We had a heck of a issue with channel changes because of apparent TDRS, and there are none within 150 miles! Closest alternate there is Army base that could have their own, but they’re nearly 70 miles away too…

We’re literally in the middle of no where land in this case… so, these are all mystery interference that we’ve given hope on determining except by luck. Such is the world of wireless infrastructure.

@Bryan1 What other equipment do you have on the tower? If it’s Mimosa equipment do you have it connected to Mimosa Cloud Management? Hunting down these issues is pretty difficult in my experience, it might help if you get the extended data from the Mimosa Cloud (just chat with support and they can hook you up) so you can correlate data over an extended period of time.

Nothing else on tower… Closed other freq is our EMS radio… on VHF. Even if you consider harmonics, it doesn’t show up.

I think the only official way to identify it is to get a spectrum analyzer in place. Something that should be at least identified, but because there’s no obvious impact in performance, it’s not on the critical discovery list.

Hi Dustin, can you explain more about LTE colocation interference with GPS? Is there any fix/patch? We have 12 x A5c on a water tank that has Verizon & ATT LTE on the tank. about 1/2 of the A5c are unable to get GPS. Thanks for the details on this issue and any possible resolution.

Hi @Bob2,

Certainly! So GPS frequencies normally run around 1600MHz. ( LTE can run on several different frequencies, but sometimes they run between 700MHz and 800MHz.
As you can see, LTE doesn’t directly interfere with GPS because they are on different frequencies. Unfortunately, it’s a thing called frequency harmonics that plays hell with GPS antennas. Harmonics happen in RF all the time. So say your LTE frequency is on 750MHz. You have a chance of also causing interference at 1500MHz as well. So in this particular case it would be the 1st overtone/2nd harmonic causing the interference.

So there isn’t a fix or a patch that can be supplied to you. The only fix for this is spatial separation between your equipment and the LTE equipment. You could also try some kind of shielding between your equipment and the LTE equipment as well. I’ve had to do a sheet metal shield around a B5c several years ago that seemed to help.

Mimosa recommends that you have at least 20ft of separation between LTE transmitters and GPS enabled Mimosa equipment. Unfortunately, you probably can’t get that on a water tower.

1 Like

No GPS appears to be a quality control issue. I just opened up 4 brand new B5c’s that Mimosa sent me as warranty replacement. 2 of the units gave the “no GPS” warning. Thinking that it could not see the sky I set up a test where it had full view of the sky, no cigar and no GPS. With the 3rd unit the Ethernet port never even came up after repeated reboots. The fourth unit actually appears to work, I was able to unlock it without the no GPS warning. The B11 that was sent with these units appears to be ok although it had some type of film scattered around the surface making it appear as though it may have been deployed prior to shipment to me.

Problem solved.
Once started, it worked perfectly.
Thank you very much to all.

Hello @Manuel_Sebastian, how did you solved the GPS issue?
Thanks in Advance.

Hi Sir! how to resolve not working gps? pls reply :slight_smile: thanks

This topic is old and done. Please post a new topic if you would like to get some help.