Known A5c 2.5.0 Firmware HTTPS Issue?

I just upgrade two brand new A5c’s to 2.5.0. Everything’s fine until I enable https. Once that happens, I’m no longer able to access the devices web management. I can still ping the devices. Rebooting the device does not fix it. I reset both devices to the factory defaults, unlocked them again, and they work fine. Enabled https again, can’t connect to them again.

I have almost all of my sectors on HTTPS and I upgraded them last week with no issues.

Is your browser trying to connect to https://dev.ice.i.p ?

yes, https://192.168.1.10

It just times out and no longer responds on http:// either. But like I said, I can still ping it.

what browser are you using?

Have not seen it on A5c yet, but might have just had it happen with a C5. Did an upgrade from factory firmware to 2.5.0. No problems until I set the IP and turned on HTTPS. Trying a reboot now. Running Firefox…

NVM, Reboot fixed it.

We upgraded approximately 100 C5 to 2.5.0 and saw the same problem. We had to issue a reboot from the A5 to get them to respond to web interface again.

We have since re-downgraded the entire network back to 2.3.3 which we find is the most stable firmware ever released.

Ya know, I ran 2.4.1.1 for months without any software related issues. Same for 2.4.0.3.

I tried to duplicate @Ryan12’s issues (couldn’t) and I know Mimosa worked with him.

I would not recommend running old firmware as @Ryan12 is suggesting.

I tried rebooting these numerous times and could never get them to come back up. I just kept https off for the time being; which isn’t preferable for obvious reasons.

@Christopher
Ya, I totally get you. Especially if you commit the sin I do and have management traffic in the same network as user traffic. (mostly)

What did Mimosa say?

Out of curiosity, have you tried a port scan?

It’s your network do as you will, but there is problems and 2.3.3 is the most stable firmware we have tried.

I’ve updated several A5c’s and an A5-14 and I’m using HTTPS on all of them, and didn’t see this problem on any of them.

John Rayfield, Jr.

Beats me. I guess I’m just crazy.

have your tried 2.5.1 to see?

Just upgraded one of my A5c’s to 2.5.1 and now I can no longer access the radio via https. Looks like this is still an issue. Tried multiple different browsers, but still will not work.

Update: Reset the radio multiple times and finally was able to connect with Microsoft Edge Browser. I was using Chrome, but can no longer connect with that browser.

1 Like

@Ethan,
Weird, at least we have someone else that is having the issue. Did you upgrade from 2.5.0? or an older firmware?

@Christopher, my A5’s are all flat layer 2 bridges, no VLANs or anything special. Maybe there is something going on there? What is your network like for your A5s that you can’t reach?

This is happening before they’re even on the network yet. They’re directly connected to my laptop.

I thought so, but I figured it would be better to ask…

Got me stumped…

Ever try that port scan?

Haven’t had a chance, but I will next time I hook one up.

Hi all,

We have identified the HTTPs issue and are working on a bug fix for this. I do not know the timeline on this, but I would expect it somewhat soon.