Mimosa B5 in a LAGG

HI Everyone.
Im trying to connect severals PTP to increase bandwidth .
Generally i do that configuring many ports of a switch as a LAGG (link aggregation)
same config on the other side , 2 or 3 pairs of PTP configured at different frequencies
and everything goes fine with other PTP config than MimosaB5.

Can i do these with mimosaB5?
as extra data ( no comparision, please) putting the ubiquiti’s PowerBeam in WDS mode
can afford that.
WDS mode avoid to put the macaddress of PTP’s antennas , and therefore works like a ethernet cable, really transparent.

Expecting comments and possible solutions
Regards
Hugo Petrucci

You should be fine, I have not used B5s in this way yet, but it should work.

B5s by default try to act as much like an Ethernet cable as they can which will benefit you. I don’t see any problem.

What kind of router are you using?

Link Aggregation should work without problems because B5s work as a transparent bridge.

Anyway… What bandwidth do you need? B5 can use 2x80 Mhz channels without additional equipment for link aggregation. We have some of them with more than 1gbps aggregated capacity.

Actually, I’ve seen problems with doing this. Assuming the following setup, router>>switch>>Mimosa units>>switch.

  1. The Mimosa units are each on a part of a total link (a member of the LAG), so there is a problem communicating with the Mimosa units. They drop off of the web management page and getting into the units’ internal web page becomes impossible.

  2. I was receiving the MAC of the router on the link coming from the switch at the end of the chain into the switch between the router & the end switch. The router’s MAC should only be inbound on the link from the router to the middle switch, so the LAG was creating a loop, as if they were 2 separate links & spanning-tree was turned off. Since the LAG was created, spanning tree was treating both links as if they were a single link, which is what it’s supposed to do. I tried both LACP & just “On” for the LAG and had the same result in both cases. Each switch showed the LAG was formed, but the problem still existed.

If anyone has any ideas, it would be appreciated.

The issue with the Management of the Mimosa equipment was because of the LAG, the switches were sending the traffic down the wrong port and will always cause erratic issues. The only solution I can think of for that situation would be to have VLAN management turned on on the Mimosa Devices and have VLANs on the interfaces leaving the switch on the correct interface to reach each device. (so put the VLAN on the interface and not the LAG, if that makes sense)

Not certain about your second problem, I would be curious about the model switch you are using.

Yes, I’m aware of the reason for the management issue. I could tolerate it, if that’s all it was. When I wanted to manage the Mimosas, I would just break the LAG temporarily. Not ideal, but workable. The problem was getting that MAC address back on the LAG from the downstream switch (Cisco 3560s). The only thing I can assume is that, due to the Mimosa units trying to use their IP addresses to communicate on the LAG, they were generating traffic on 1/2 the LAG link, which would NOT be normal LAG traffic, and somehow that was causing the loop. The Mimosa units’ Ethernet ports think they’re on a normal Ethernet connection, not 1/2 of one (one leg of the LAG).

One way around this would be to make 2 layer 3 connections through the Mimosas, each on a different network. However, the building they’re supplying, while across the parking lot, is close enough to allow roaming. If I go layer 3, I loose the ability for the roaming, wireless clients, such as cell phones, to maintain their IP address and just roam from WAP to WAP. Instead, they would need a new connection with a new IP address in the building supplied by the Mimosas.

For your suggestion to put the VLAN on the interface & not the LAG, I’ll have to think about. To run the Trunk over the link and set up the LAG, the entire link becomes part of the LAG. The interfaces on the switches are joined. I don’t know of a way to also put an Access VLAN on the port that wouldn’t be part of the LAG, just for the Mimosas to use. In other words, when creating the LAG, the interfaces are bundled. The LAG is NOT created on a per VLAN basis.