MIMOSA B5x LAN autonegotiation issue

Hi, this is the second time we are installing B5x radios. 2 B5x devices are connected to 2 individual gigabit POE adapters and cascaded using a certified CAT6 patch cord.

2 weeks has passed since then and we now had a LAN issues. We tried changing the patch cord and the POE adapters but none of them still worked. Out of curiosity, i disabled the LAN autonegotiation of one of the radios and it worked, 1Gbps FD using the same setup. And then i tried enabling it again, no LAN.

What’s weird is we tried to use an unmanaged gigabit switch to connect the 2 B5x radios and autonegotiation seemed to work fine.

We used new cables for this installation, ToughCable Pro and TC connectors, MIMOSA NID, proper grounding were secured, and we are using LPI grounding system. What could be the issue? The only difference from our first B5x installation to this one was these radios used the latest Mimosa firmware (I think it was. 2.11.1) . The previous one was using 2.10.0.