Older A5c firmware

i need older A5c firmware version 2.5.4

You’ll need to contact Mimosa support.