Problem with throuput, ethernet link up-down

I have B5c

In dashboard i have 780 rx but i get only 30 mbps.
Try on many channels!!!

The ethernet problem its always down-up
Change POE, Cable cat6.
I dont know how to fix this problem

Help me please

Which firmware are you using?

Have you verified the issue is not in the switch/router or possibly bad Ethernet ends? How long is your cable, if it’s over 100 Meters you are going to have problems. Have you verified the whole cable doesn’t have damage to it that could be causing issues?

It also looks like you have noise on your local side of the link. As well as that you are posting images from two different sides of the link which isn’t helpful.

Following up on William5’s comment:

Is there anything programmed into the switch port that the device is connected to? I could see where UDLD, Port Security, or BPDU settings could cause a problem if not configured correctly.

Our not facing Throughput issue, but we facing Ethernet flapping. B5c after 1.5Years will be happen. C5C also started. (After swap new equipment solved). Many things we try it. e.g: Long LMR400 equipment keep rack, SFTP cat6 cable, 10mm grounding. Same Result.

B5c Throughput powerful, we install 24KM with 0.6mx1.2m antenna get 500Mbps Full Duplex. Half duplex 1 Gbps “TCP”.
Because flapping issue we also try another product(Cambium). the product have sfp port and price same with B5c.
If Mimosa still can’t solve this issue, more user will be change to another product.

1.5.1 firmware …

i just have 10 meter long cable

i use mikrotik 1016
is there a way to fix this

These can be more tricky to troubleshoot, I do not believe this is a defect with Mimosa as I have seen this issue with multiple brands.

This is what I look for:

  1. The most important point, is everything grounded good? (Is it windy when this flaps? That is an indicator)

  2. Does your UPlink cable to go an SPF on your CCR? If so change it out, or change where this links in to another port on the CCR. If the problem follows it is probably not the CCR.

  3. Re-seat each cable end. If you did #2 then you have to only have to go up and re-seat the radio side. Possible it ‘wiggled’ in the wind. (Again is it windy?) I had this happen once on a B5. In theory it is also possible there is\was dust on the end when it was installed and now it is messing with one of pairs.

  4. Change the cable. Make sure it is a shielded and grounded (and the radio)

  5. Put a different switch midspan (netonix is what I use or cisco if I have something laying around.


  1. If the above does not work, change the radio out and test on the bench

Keep negotiation on the port when testing to ‘auto’

@Willam5 there is a document but I can’t find it on mimosa cabling troubleshooting recommendations maybe you know offhand?

Good luck!

1 Like

@Shannon1, you mean this?

1 Like

Yep thats it --I thought that may help this help in this case. I had a meeting to go to and in my haste couldn’t locate it.

1 Like