Problems uploading initial firmware

I am wondering if this is a common problem. When we first set up a new C5 we have several that the firmware uploads to and then sits there on verifying image but nothing happens after that. Sometime if a reboot and try several times they will then complete. I have tried on windows and linux laptops and desktops using Chrome, Opera, Firefox. Tried plugging into a switch and directly into the computer ethernet port same result. Eventually if I open enough new radios I get one that works right now have 4 that will not update

1 Like

I have a similar problem on a B5 the initial upload of firmware just hang there, Hopefully it doesn’t brick it and just manually restart it

I had the same problems with all modern browsers. I tried IE on Windows 10 and it worked perfectly.

Give it a shot and please let us know if it works for you. Start, Run, iexplore.


No windows 10 at this company we only use linux and some windows 7.

1 Like

I think I have figured out what the issue is. When the radio is in dhcp plus static mode the radio jumps back and forth between dhcp and static address. I have seen this behavior on the A5 units. Always have to put them in static or cant get back into them. I tried from mikrotik, linksys and cambium router issuing dhcp and could see lease offered and then it drops and goes back to static ip and then few seconds later tries to grab a lease again. A few reboots and got enough time to change to static only and no problems after that.

1 Like

I was just about to comment that fix. I spent 1 hour on chat with Mimosa support last week. Not once did they ask me how I was hooked up to the radio.

But if you connect directly to the radio with static ip 192.168.1.X then you can upload firmware!

I’ve had this same problem on every single C5 we deploy. It takes over 30 minutes to firmware upgrade. We use Mac OS and have always used a static IP. Once it’s past the initial upgrade, it works fine.

1 Like

We have an Android/iOS mobile APP coming out that will greatly simplify the unlock, firmware load, configuration and aiming. This solves the problem of DHCP vs. Default Static. It’s approaching beta at the end of the month.

A question on the DHCP vs. Static IP issue. Our current default IP settings are a static/fallback IP of with DHCP enabled. If a DHCP server is present, the C5 will automatically switch it’s IP to whatever is learned from DHCP. If you are connected with the static IP when this happens you will loose connectivity to the device.

The purpose we do this is to help automate the configuration process. i.e.: when you connect a C5 to an A5 it will automatically get an IP address.

We are kicking around a few ideas to make setup easier w/out the mobile APP. What are your thoughts?

A) Change the default to NOT get an IP address via DHCP. It would be set to static IP only. You would need to change this setting to use DHCP.

B) Change the DHCP behavior so, by default, it will only request an IP address via the wireless link. This would allow you to get into the C5 via the ethernet port, manage software upgrades, etc and not have the IP address change. You would be allowed to change DHCP so it will request via the ethernet port.

If anyone has any clever ideas please feel free to share.

1 Like

Just set the radios to fixed IP only for initial setup. As far as the Android app–who cares just a gimmick really just like the 2.4 AP we never use on the A5. We need real features first like pppoe and routing in the C5.

1 Like

I definitely can confirm that this DHCP/Static IP bouncing caused trouble in our lab as well.

We’ve been trying to test a bunch of C5 new from the box and couldn’t figure out why the initial upload was always terminating with “Invalid Image” until I read this and put the C5 under a DHCP server.
Used Safari on MacOS and bam, uploaded and installed right away.