Problems with GPS Firmware

Just upgraded an A5-14 AP and one C5 client to the new GPS firmware. The client connected after about 5 minutes then the AP rebooted about 30 seconds later. Logged back in and client never re-connected. GUI became unresponsive for the AP and the AP rebooted on its own about 3 times. The client never connected after 15 minutes.

Reverted back to wifi mode rebooted client and then rebooted AP after changing back to TDMA mode. After 10 minutes no client connect and then AP rebooted a couple of times on its own. Gui was very unresponsive while in TDMA mode. Rebooted AP with POE switch as I could not fully load GUI.

Reset AP as wifi interop and everything is working again. This AP and client had been up 179 days with no issues until now.

Hmm… you might want to check the AGC. I have no experience with it personally yet, but what it sounds like it does is ignore any and all signals that are not at least that strong.

so if your client hooks up at -65 but AGC is at -62 it will never connect. set AGC to -67 and all will be fine.

AGC was set for -70 for this test and client has a -55 on transmit so that should not be an issue and was normally set in manual at -65 for wifi interop mode. Also does not explain why AP became unstable as far as GUI and rebooting in TDMA mode

There may be a different SSID and Passphrase between GPS-Sync and WiFi Interop modes.

The C5 should reboot to follow the A5 after a protocol change. If it can’t find the AP, it will revert modes and run another site survey.

The A5 should reboot after a protocol change, but rebooting multiple times is not normal. Please send A5 and C5 logs to support via chat or email so we can take a look.

Tried to enable GPS again on the A5-14 AP. Updated both client and AP with latest firmware. Followed instructions for GPS completely. After 30 minutes no connection of the client. Moved back to WiFI mode connected immedietly.
Tried rebooting client and then switch to GPS nothing after 20 minutes. Tried this 5 or 6 times but client will not connect to GPS mode. Is there something broken in AUTO mode on the client? Seems like it is never switching to GPS mode

Also notice AP reboots frequently in GPS mode. Uptime counter resets in AP so I am assuming it reboot. This AP works perfectly when in WiFI interop mode.

Tried various AGC settings but set it to -75 mostly and client is at -50 so should be no problem

Check your PSK on the A5 after a changing over to GPS. We ran into this and it took awhile to figure out what was going on.

1 Like