So what did you do from 2:30AM to 4:00AM

Well this is part my fault as I have my mimosa units installed with the factory power bricks plugged into a UPS with no way to remotely reboot them, and that will now change next week!! one of the reasons i have not changed to remote control power is I have A BS reply from one of you guys from before the forums got set up that says something to the effect " Do to the Grounding and Electrical design of our power supplies it is best to use what is supplied with your radio to power it "

BUT to the meat of my post here!!

Come on guys, For the past three upgrades I have ran I have had units that take a crap when it is told to reboot after the firmware upgrade. The radio is still passing data but I cannot log into the web GUI and have NO COMMAND LINE INTERFACE… I am stuck like a fat kid on crack… Now I gota get up and go drive for 2 hours to reboot 3 radios…


Give us the options to


download log files

trigger wget to fetch firmware

command to install above firmware

ping and MTR tools

We are not asking for the source code, Just a Command Tool Interface!!

Would it not be fruitful to get a UPS with an IP management card? you could then remote power the UPS ports. Always good to ensure a backup circuit is in place also even if it is just a 2Mb DSL to allow remote management activities such as the above mentioned.

I am going to get a web controlled relay and just interrupt the 110v through the contacts of the relay… on my sites that have grid power… the others will be moved over to DC so that my inverters can relax. This is a no issue as how to do it… I am just upset at some of the general BS canned responses i have gotten about things and now one of the has bitten me a few times…

Check out these locations on google maps…

29.526027, -91.403379 "Boat Only"
29.442758, -91.095342 "Boat Only
29.777293, -91.757574 "52 Min Drive"
29.815813, -91.103160 “45 Min Drive”

You can’t get DSL where we are at. we have back up links, but a backup does no good when the primary is still passing data and you cannot access it… Lets say i wanted to get the logs from a device that took a crap but did not update to the logging server, under the current operations you cant do that… I ran digital loggers with the UBNT gear and a watch dogg if it did not ping home the digital logger reboots every thing…

Before the first mimosa units were shipped i was asking questions about the ability to power from DC and to remote reboot and it got a canned response… It just makes my skin crawl when I feel like i get shrugged off… I know DC power works plenty of people are now doing it… I just did not want to be the first one to smoke a $800 radio because i used a VHP and not a HP…

Hi Samuel,

Sorry to hear about the trouble you had. We know there are plenty of operators using alternate power supplies and/or IP power switches. Perhaps some of them could chime in here. If you have a specific device you want to use, we would be happy to review the specifications and provide guidance. There is one such post here: B5c on Netonix POE switch

Look at DataProbe. They have devices that monitor the network through pings and allows remote reboot. So if a radio locks up and the ping fails, it will automatically power cycle. You can set the ping to ping the B5 itself or an internet address to verify internet service. I have used them in the past. I believe they are coming out with some PoE powered monitors as well.

1 Like

We have 3 links all on DC powered Netonix switches. This is because 4 of these sites don’t have any A/C backup power without us driving out there and hooking up our Honda generator. With battery backup we don’t have to start worrying about power for 12 hours or so. This solves all our problems except for ice storms.

We are using everything from the small WS-6-MINI to a WS-12-400-AC that has been modified for DC backup batteries. They all work fine with the Mimosa B5c units. We use VH power setting and there is a watchdog feature to reboot connected equipment but I have never used it. It sounds like putting one of these Mini-6 switches at your site would solve a lot of headaches for you. These switches pass through the DC voltage to the 48 volt equipment and our batteries float at 52-53 volts. We’ve had no problems and have been very happy with this solution. The switches also power all our Mikrotik equipment at each site.

Just my 2 cents.

But I think some of you are missing the OP’s point, which I agree with. THERE SHOULD BE A CLI. There’s Linux in there (or something like it) and a CLI would be very useful. Especially when Mimosa does a compile and forgets to include the SSL library and you had HTTPS turned on… but in general it’s just nice to have emergency back up measures like it.

Hi Harold
Do the WS-6-Mini have a watchdog feature that will repower a port on failure? We seem to have 2 B5c that require cold reboots to work properly. Like yourself this units are remote and expensive to visit!

Yes, the watchdog will either ping the Mimosa unit connected to the unit or I believe ping through the port to a remote IP address or web address to test for connectivity. I have never used this feature but here is a quote from the watchdog setup screen. “If you enter a Hostname or IP address the watchdog will use an ICMP ping. If you enter a URL the watchdog will use an HTTP request.”

These settings are per port. It will reset power to the port after a specified amount of time and/or notify you via smtp. The little 6 port has all the features of the advanced 24 port switches they sell. They also sell some DC regulated switches that will power 48 volt devices from any voltage down to 12 volts but I have never tried any of those. We use the 6 and 12 port 48 volt switches at our tower sites.

Yes, I agree that there should be a CLI but the conversation appeared to have moved on to ways to remote boot the Mimosa equipment if necessary.

Thanks Harold
We have a situation at the moment where the AP and Station on the 2nd leg on a 2 leg system has lost association. Both units have watchdog activated and that has not brought them up as I suspect they will need cold rather than warm reboot. We have access to the AP and rebooting it from its web page does not solve the problem. Was your problems similar?

Sorry, I’m no help. We honestly haven’t had much in the way of problems. I would get Mimosa Support involved to see if they can help. We don’t even have watchdog enabled on any of our links. I suppose you’ve done the normal stuff, change frequencies, gender, try 2X20, etc.?

Hi Harold
Yes and they have been involved and trying to be very helpful. But it would be good to have a “concrete” reason why it is going off rather than try another firmware. Issues seem to have arisen with 1.30 and 1.3.1. But we will get there. The cold boot ability with the switch would at least reflect a site visit!!!