TCP Very low throughput - downstream B5


We encounter a big problem with a link with B5 in PTP mode with tcp dowmstream.
The firmware is 1.4.4 on each B5.
We made a multiple tests with IPERF on each side of the link.
Our configuration is :

  • Switch ubiquiti Thoughswitch 8 ports with B5 in AP <- 3.1 miles 4.9km -> B5 in Station and Switch ubiquiti Thoughswitch 8 ports.
    Link parameter : Gender 50/50 TDMA 8ms Rate PER Phy Conservative
    The Eth is 1G on each device.
    Line of sight very good fresnel zone.
    Ping : 20 ms up and down.

The link hasn’t any problem with Iperf test on UDP and TCP upload stream ( Station to Access Point) : our test 100 Mb upstream in TCP.
The link has few problem with Iperf test on UDP and a very low capacity on TCP dowmstream. (Access Point to Station) : and max 5 - 6 Mb - downstream in TCP.

We made a lot of tests with them but nothing change.

Fisrt we used 2x80 Mhz feature and after we test 1x80 Mhz. Same result.

Recently we had installed a B5 link which presents a similar problem of significant dissimetry between the upstream and downstream rates in TCP with IPERF. ( 100 Mb vs 1 Mb) with the same features.
We had to stop this link…

But we also have other older B5 links that have been updated to firmware 1.4.4, after their installation and we haven’t found this type of problem.

Do we have to downgrad to 1.4.1 version firmware ?
Can you help us?

1 Like

Presumably the test is running from/to a device connected to the switches at each side? Remove the Toughswitches and see if the problem remains.


I asked two of my technicians to reproduce this model in our office.
We have reproduced the problem in our office.
They have downgraded the firmware to 1.4.1 and it has not changed anything.
They then tested the configuration without the switches and with the Mimosa power supplies.
We obtained a slight improvement by reaching on the download a max of 25Mb in tcp.
But the upload stream is normal and efficient.
With two radios ubiquiti we don’t encounter this problem with the same configuration.

They have to do the test with a Netonix switch

We performed another test.
One of my technicians changed the configurations. The access point became the station and the station became the access point.
And we find that the problem followed this change.
We note that the TCP flow problem in the downstream direction from the access point to the station, follows the program.

Hi Frederic,

Would you please send the Support logs (.tar files) to We will be able to diagnose your problem further that way. Downgrading to 1.4.1 is not a known solution, so we recommend staying with 1.4.4 (or 1.4.5 beta if you have it).

Hi Chris,

I will send the support logs from the real PTP B5 link to
First the feature PTP B5 link was 2x80 Mhz.
Now we reduce this PTP B5 link to 1x80mhz and we always have the problem.
The next week i will send the support logs of the link which reproduce the problem in our office.
We don’t test with the firmware 1.4.5.
Thanks for your help.

1 Like

it’s same with my case. But when change the cheap cable from PoE to PC the problem is solved.