Trouble with download speed (always 1.5 Mbits) - A5 and 8 C5 units

We have a client that’s having troubles with download speeds for everything downstream from an A5. At the switch where the A5 is, we get 100/100Mbits. When we go to any of the buildings where there is a C5 the upload will be around 50-80Mbits, but the download speed is always 1.5Mbits. Can anyone think of what might cause this?

All C5s are using the default plan which is set to 1000Mbps for Up and Down. Using SRS for wireless protocol. The interface to the A5 negotiated at 1Gbit and there aren’t any interface errors.

One other item that seems odd in our troubleshooting is that STP frames are not being passed over the A5 link, so each switch on a C5 thinks it’s the root bridge. This issue doesn’t feel related to the speed problem, but it’s one that I’d like to understand and resolve if possible.

Thanks for anyone’s input!

Two things:

  1. Do you potentially have any traffic shaping plans created on the AP?
  2. Are you in WiFi Interop or SRS mode?
1 Like

Thanks for the response.

  1. The default plan is used and it’s unchanged - using 1000 Mbps for all fields
  2. SRS mode.

Are you using the same IP for your testing at each location?

Would you be able to setup an iPerf server (or an FTP server, something that can pass a lot of traffic and give you a measurement) at the A5 location and test just the A5-C5 link?

What firmware are you using on the A5/C5s?

Do you have multiple A5s that you are seeing this on or just the one?

Have you tried changing the channel on your A5?

1 Like

We’ve just been using (among others) for testing and we’re using the same server for each test.

Firmware is 2.5.2.

We are seeing this on all of the C5s.

Yes we have changed the channel on the A5 and also gone completely auto with the same results.

We can setup an isolated internal speed test.


A quick clarification, I mean Access Points "A5"s. Do you have more then one of them and are you seeing the same issue for all clients or do you only have 1 A5. I think you were pretty clear in your first message, you have an A5 and all the clients connected to it are seeing the same issue. I will always try to ask clarifying questions and not ones that you have already answered previously.

Have you tried messing around with the AGC controls? (Under Channel and Power in the A5)

1 Like


Would you be willing to come to chat in the morning and talk to me or one of my guys? I would love to be able to help figure out what’s going on for you.

1 Like

We are headed onsite now and have engaged Mimosa support to look at this with us.

@DustinS if you’d like to get involved as well, we’d welcome all the help we can get. I have two questions that might help us push things along.

  1. Should BPDUs be able to traverse the A5? All the switches behind the C5s think they are the root bridge and they see no spanning-tree over the wireless.
  2. Is there a way from the A5 to temporarily block C5 clients? We would like to disable all clients except one and test to see if there is any change. If it works, then we want to bring each C5 back online one at a time to see if it’s one site causing the problem.

@William5 - Sorry about that! Yes we have other A5s on campus that feed other C5s and we don’t have any problems with those. Just this one A5.

I believe we have changed AGC controls previously, but we can revisit those settings.

I received an answer regarding spanning tree - “Mimosa A5/A5c links do not support BPDUs.”

So that explains what we were seeing on the far switches.

No problem, I get confused sometimes so I try to be as clear on my thoughts as possible.

The one weak client that is really close concerns me a bit. But that shouldn’t effect the whole sector this significantly… (or at least I don’t see my weaker clients effecting my sectors this much…)

What does your Channel & Power page show? (I mostly just care about the spectrum, but if you don’t mind showing the whole page it might help…)